Nexus slowdown

Incident Report for Nexus

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 12:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2026 - 11:25 UTC

Investigating

The Nexus platform is currently experiencing slowdown, the development team is actively investigating and will have a resolution shortly. The hardware is operational so any queued jobs will continue to execute normally.
Posted Aug 25, 2026 - 08:59 UTC
This incident affected: Web interface and REST API.