Issues with a new operation type (ClExpr) causing python exceptions in qnexus
Incident Report for Nexus
Resolved
Nexus Lab has been updated with new versions of pytket and qnexus, and the issue is resolved.

If you're working with qnexus locally, please update to the latest versions to avoid the issue (latest version is 0.8.1 at the time of writing).
Posted Nov 13, 2024 - 15:28 UTC
Update
Correction: we're working on a fix for Nexus Lab which will fix this problem. Please bear with us until we have updated the Nexus Lab.
Posted Nov 13, 2024 - 10:28 UTC
Identified
If you are using qnexus to interact with our services and seeing an error "AttributeError: type object 'pytket._tket.circuit.OpType' has no attribute 'ClExpr'", please update your installation of qnexus to v0.8.0 or newer.

We've just released an update to Nexus's lab which should fix this problem for users who are using qnexus within the Nexus Lab.
Posted Nov 13, 2024 - 10:25 UTC
This incident affected: Lab.