Maintenance has been completed. Apologies that it overran.
Posted Mar 17, 2025 - 12:12 UTC
Verifying
Verification is currently underway for the maintenance items.
Posted Mar 17, 2025 - 12:07 UTC
Update
We've found unexpected issues while doing maintenance, so we think maintenance may take up to 30 minutes longer than estimated.
Posted Mar 17, 2025 - 11:21 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2025 - 10:30 UTC
Scheduled
Nexus will be undergoing essential maintenance to upgrade our internal systems. This is to ensure the their continued performance, reliability, and security.
Posted Mar 13, 2025 - 19:54 UTC
This scheduled maintenance affected: Web interface, REST API, and Lab.